Ir al contenido

CalDAV

De Mexpedia

Calendaring Extensions to WebDAV, o CalDAV, es un estándar de Internet que permite a un cliente acceder a información de planificación en un servidor remoto. Extiende WebDAV (protocolo basado en HTTP para la manipulación de datos) y utiliza iCalendar como formato para los datos. El protocolo de acceso está definido por el RFC 4791. Permite que varios clientes accedan a la misma información, facilitando la cooperación. Muchas aplicaciones, tanto clientes como servidores, son compatibles con este protocolo. Extensiones de CalDAV para planificar de forma automatizada también están estandarizadas, como RFC 6638.

El ejemplo está basado en el RFC 4791:

Solicitud:

REPORT /bernard/work/ HTTP/1.1
Host: cal.example.com
Depth: 1
Content-Type: application/xml; charset="utf-8"
Content-Length: xxxx

<?xml version="1.0" encoding="utf-8" ?>
<C:free-busy-query xmlns:C="urn:ietf:params:xml:ns:caldav">
<C:time-range start="20060104T140000Z" end="20060105T220000Z"/>
</C:free-busy-query>

Respuesta:

HTTP/1.1 200 OK
Date: Sat, 11 Nov 2006 09:32:12 GMT
Content-Type: text/calendar
Content-Length: xxxx

BEGIN:VCALENDAR
VERSION:2.0
PRODID:-//Example Corp.//CalDAV Server//EN
BEGIN:VFREEBUSY
DTSTAMP:20050125T090000Z
DTSTART:20060104T140000Z
DTEND:20060105T220000Z
FREEBUSY;FBTYPE=BUSY-TENTATIVE:20060104T150000Z/PT1H
FREEBUSY:20060104T190000Z/PT1H
END:VFREEBUSY
END:VCALENDAR

Implementaciones

[editar | editar código]

La lista del servidor CalDAV incluye::[11]

Véase también

[editar | editar código]

Referencias

[editar | editar código]
  1. ↑ iCal at Apple Mac OS 10.5.
  2. ↑ iCal Server, Apple Mac OS 10.5.
  3. ↑ Calendar Server Archivado el 30 de abril de 2008 en Wayback Machine., Darwin.
  4. ↑ CalendarSync
  5. ↑ CalDAV-Sync
  6. ↑ «DAVdroid». davdroid.bitfire.at. Archivado desde el original el 11 de septiembre de 2017. Consultado el 16 de noviembre de 2015. 
  7. ↑ TaskSync
  8. ↑ CalDavZAP
  9. ↑ EVO Collaborator for Outlook
  10. ↑ 10,0 10,1 Horde Groupware
  11. ↑ «CalDAV Servers (English)». Archivado desde el original el 24 de octubre de 2008. Consultado el 7 de enero de 2014. 
  12. ↑ «Baikal». Archivado desde el original el 14 de noviembre de 2015. Consultado el 17 de noviembre de 2015. 
  13. ↑ «Bynari Collaboration Suite». Archivado desde el original el 4 de agosto de 2012. Consultado el 17 de noviembre de 2015. 
  14. ↑ «DAViCal». Archivado desde el original el 1 de octubre de 2013. Consultado el 17 de noviembre de 2015. 
  15. ↑ EVO Mail Server
  16. ↑ Kerio Connect
  17. ↑ Oracle Communications Calendar Server
  18. ↑ SOGo
  19. ↑ sabre/dav
  20. ↑ Zimbra
  21. ↑ ownCloud
  • RFC 2616 @– HTTP
  • RFC 3744 @– WebDAV Protocolo de Control del Acceso
  • RFC 4791 @– CalDAV
  • RFC 4918 @– WebDAV
  • RFC 5545 @– iCalendar
  • RFC 5546 @– iTIP