Ir al contenido
Menú principal
Menú principal
mover a la barra lateral
ocultar
Navegación
Página principal
Cambios recientes
Página aleatoria
Ayuda sobre MediaWiki
Buscar
Buscar
español
Apariencia
Crear una cuenta
Acceder
Herramientas personales
No has accedido
Discusión
Contribuciones
Crear una cuenta
Acceder
Edición de «
Session Description Protocol
»
Página
Discusión
español
Leer
Editar
Editar código
Ver historial
Herramientas
Herramientas
mover a la barra lateral
ocultar
Acciones
Leer
Editar
Editar código
Ver historial
General
Lo que enlaza aquí
Cambios relacionados
Información de la página
Apariencia
mover a la barra lateral
ocultar
Advertencia:
no has iniciado sesión. Tu dirección IP se hará pública si haces cualquier edición. Si
inicias sesión
o
creas una cuenta
, tus ediciones se atribuirán a tu nombre de usuario, además de otros beneficios.
Comprobación antispam. ¡
No
rellenes esto!
'''Session Description Protocol''' ('''SDP'''), es un [[Protocolo (informática)|protocolo]] para describir los parámetros de inicialización de los flujos multimedia. Corresponde a un protocolo actualmente redactado en el RFC 4566 por la [[IETF]], de los anteriores RFC 2327 de abril de 1998 y RFC 3266 de junio de 2002. SDP está pensado para describir sesiones de comunicación [[multimedia]] cubriendo aspectos como anuncio de sesión, invitación a sesión y negociación de parámetros. SDP no se encarga de entregar los contenidos propiamente dichos sino de entablar una negociación entre las entidades que intervienen en la sesión como tipo de contenido, formato, y todos los demás parámetros asociados. Este conjunto de parámetros se conoce como ''perfil de sesión''. SDP se puede ampliar para soportar nuevos tipos de medios y formatos. Comenzó como componente del [[SAP Business Suite|SAP]] (''Session Announcement Protocol''), pero encontró otros usos en conjunto con [[Real-time Transport Protocol|RTP]] (''Real-time Transport Protocol''), [[Session Initiation Protocol|SIP]] y como formato independiente para describir sesiones [[multicast]]. == Descripción de la sesión == Una sesión se describe con una serie de atributos, cada uno en una línea. Los nombres de estos atributos son un carácter seguido por '=' y el valor respectivo. Existen parámetros opcionales, denotados con '=*'. Los valores pueden ser una cadena [[ASCII]], o una secuencia específica de tipos separada por espacios. La sintaxis de SDP se puede ampliar y ocasionalmente se agregan nuevos atributos a la especificación. A continuación se muestra un formato para el uso de SDP: Descripción de la sesión v= (Versión del protocolo) o= (Origen e identificador de sesión) s= (Nombre de sesión) i=* (Información de la sesión) u=* (URI de descripción) e=* (Correo electrónico) p=* (Número telefónico) c=* (Información de conexión) b=* (Cero o más líneas con información de ancho de banda) Una o más líneas de descripción de tiempo (Ver abajo "t=" y "r=") z=* (Ajustes de zona horaria) k=* (Clave de cifrado) a=* (Cero o más líneas de atributos de sesión) Cero o más descripciones de medios Descripción de tiempo t= (Tiempo durante el cual la sesión estará activa) r=* (Cero o más veces de repetición) Descripción de medios, si está presente m= (Nombre de medio y dirección de transporte) i=* (Título) c=* (Información de conexión) b=* (Cero o más líneas con información de ancho de banda) k=* (Clave de cifrado) a=* (Cero o más líneas de atributos de sesión) == Enlaces externos == * http://tools.ietf.org/html/rfc4566 * http://tools.ietf.org/html/rfc3266 * http://tools.ietf.org/html/rfc2327 * [http://www.jcp.org/en/jsr/detail?id=141 JSR 141: SDP API] (para [[Java platform]]) {{Control de autoridades}} [[Categoría:Protocolos de Internet]] [[Categoría:Protocolos de nivel de sesión]]
Resumen:
Al guardar los cambios aceptas los
términos de uso
y liberas de forma irrevocable tu contribución conforme a los términos de las licencias
licencia CC BY-SA 4.0
y
GFDL
. Aceptas igualmente que un hipervínculo o URL es atribución suficiente conforme a la licencia Creative Commons.
Cancelar
Ayuda de edición
(se abre en una ventana nueva)
Buscar
Buscar
Edición de «
Session Description Protocol
»
Añadir idiomas
Añadir tema