Ir al contenido
Menú principal
Menú principal
mover a la barra lateral
ocultar
Navegación
Página principal
Cambios recientes
Página aleatoria
Ayuda sobre MediaWiki
Buscar
Buscar
español
Apariencia
Crear una cuenta
Acceder
Herramientas personales
No has accedido
Discusión
Contribuciones
Crear una cuenta
Acceder
Edición de «
STARTTLS
»
Página
Discusión
español
Leer
Editar
Editar código
Ver historial
Herramientas
Herramientas
mover a la barra lateral
ocultar
Acciones
Leer
Editar
Editar código
Ver historial
General
Lo que enlaza aquí
Cambios relacionados
Información de la página
Apariencia
mover a la barra lateral
ocultar
Advertencia:
no has iniciado sesión. Tu dirección IP se hará pública si haces cualquier edición. Si
inicias sesión
o
creas una cuenta
, tus ediciones se atribuirán a tu nombre de usuario, además de otros beneficios.
Comprobación antispam. ¡
No
rellenes esto!
'''STARTTLS''' es una extensión a los [[protocolos de comunicación]] de [[texto plano]], que ofrece una forma de mejorar desde una conexión de texto plano a una conexión cifrada ([[Transport Layer Security|TLS o SSL]]) en lugar de utilizar un [[Puerto (informática)|puerto]] diferente para la comunicación cifrada. STARTTLS para [[IMAP]] y [[POP3]] está definido en el RFC 2595, para [[SMTP]] en RFC 3207, para [[File Transfer Protocol|FTP]] en el RFC 4217, para [[XMPP]] en el RFC 6120, para [[LDAP]] en el RFC 2830, y para [[NNTP]] en el RFC 4642. == Estratificación == TLS es neutral a las aplicaciones, en palabras de RFC 5246. Una ventaja de TLS es que es independiente del protocolo de aplicación. Protocolos de nivel superior pueden usarse sobre el protocolo TLS transparente. El estándar TLS, sin embargo, no especifica cómo los protocolos añaden seguridad con TLS, las decisiones sobre la forma de iniciar el handshaking TLS y la forma de interpretar los certificados de autenticación que se intercambian se deja a criterio de los diseñadores e implementadores de protocolos que se ejecutan sobre TLS.<ref>{{cita web |autor=Tim Dierks |autor2=Eric Rescorla |título=The Transport Layer Security (TLS) Protocol |url=//tools.ietf.org/html/rfc5246 |editorial=[[RFC Editor]] |fecha=agosto de 2008 |fechaacceso=8 de octubre de 2009}}</ref> El estilo utilizado para especificar cómo utilizar TLS coincide con la distinción de la misma capa que está convenientemente soportada por varias implementaciones de biblioteca de TLS. Por ejemplo, la extensión SMTP RFC 3207 ilustra con el siguiente diálogo como un cliente y el servidor pueden iniciar una sesión segura:<ref>{{cita web |autor=Paul Hoffman |título= SMTP Service Extension for Secure SMTP over Transport Layer Security |url=//tools.ietf.org/html/rfc3207 |editorial=[[RFC Editor]] |fecha=febrero de 2002 |fechaacceso=8 de octubre de 2009}}</ref> S: <waits for connection on TCP port 25> C: <opens connection> S: 220 mail.example.org [[ESMTP]] service ready C: EHLO client.example.org S: 250-mail.example.org offers a warm hug of welcome S: 250 STARTTLS C: STARTTLS S: 220 Go ahead C: <starts TLS negotiation> C & S: <negotiate a TLS session> C & S: <check result of negotiation> C: EHLO client.example.org<ref>The last line in the example added for clarity. See e.g. the thread started by {{cita web |autor=Paul Smith |título=STARTTLS & EHLO |url=http://www.imc.org/ietf-smtp/mail-archive/msg05452.html |obra=ietf-smtp mailing list |editorial=[[Internet Mail Consortium]] |fecha=26 de enero de 2009 |fechaacceso=8 de octubre de 2009 |urlarchivo=https://web.archive.org/web/20090808131835/http://www.imc.org/ietf-smtp/mail-archive/msg05452.html |fechaarchivo=8 de agosto de 2009 }}</ref> . . . == Puertos SSL == Antes de que STARTTLS estuviera bien establecida, varios puertos TCP se definieron para protocolos bien conocidos que establecían primero la seguridad SSL, y luego presentaban un flujo de comunicación idéntico al anterior protocolo sin cifrar. Estos ya no se recomiendan, ya que STARTTLS hace un uso más eficiente de los escasos números de puerto y permite una configuración más sencilla del dispositivo.{{cr}} Algunos ejemplos son: {| class="wikitable" |- ! Protocolo !! Propósito !! Puerto Normal !! variante SSL !! puerto SSL |- | [[HTTP]] || Servidor web || 80 || [[HTTPS]] || 443 |- | [[SMTP]] || Envío de correo electrónico || 25 || [[SMTPS]] || 465 |- | [[IMAP]] || Lectura de correo electrónico || 143 || [[IMAPS]] || 993 |- |} == Referencias == {{listaref}} ==Enlaces externos== * [http://www.checktls.com/tests.html Pruebas y herramientas para SMTP TLS] (el "Receiver Test" muestra diálogos como el de más arriba) {{DEFAULTSORT:Starttls}} {{Control de autoridades}} [[Categoría:Estándares de Internet]] [[Categoría:Correo electrónico]] [[Categoría:Protocolos de nivel de aplicación]] [[fr:StartTLS]]
Resumen:
Al guardar los cambios aceptas los
términos de uso
y liberas de forma irrevocable tu contribución conforme a los términos de las licencias
licencia CC BY-SA 4.0
y
GFDL
. Aceptas igualmente que un hipervínculo o URL es atribución suficiente conforme a la licencia Creative Commons.
Cancelar
Ayuda de edición
(se abre en una ventana nueva)
Buscar
Buscar
Edición de «
STARTTLS
»
Añadir idiomas
Añadir tema