Ir al contenido
Menú principal
Menú principal
mover a la barra lateral
ocultar
Navegación
Página principal
Cambios recientes
Página aleatoria
Ayuda sobre MediaWiki
Buscar
Buscar
español
Apariencia
Crear una cuenta
Acceder
Herramientas personales
No has accedido
Discusión
Contribuciones
Crear una cuenta
Acceder
Edición de «
Referer
»
Página
Discusión
español
Leer
Editar
Editar código
Ver historial
Herramientas
Herramientas
mover a la barra lateral
ocultar
Acciones
Leer
Editar
Editar código
Ver historial
General
Lo que enlaza aquí
Cambios relacionados
Información de la página
Apariencia
mover a la barra lateral
ocultar
Advertencia:
no has iniciado sesión. Tu dirección IP se hará pública si haces cualquier edición. Si
inicias sesión
o
creas una cuenta
, tus ediciones se atribuirán a tu nombre de usuario, además de otros beneficios.
Comprobación antispam. ¡
No
rellenes esto!
{{mala traducción}} * HTTP referer (un error ortográfico del término referrer, término erróneo históricamente) es el nombre de un campo de cabecera del [[Http|HTTP]] opcional que identifica la dirección de la página web (es decir, la [[Uniform Resource Identifier|URI]] o [[Internationalized Resource Identifier|IRI]]) desde la que se realiza la solicitud. A través del chequeo del campo referer, el servidor del nuevo sitio web puede determinar de dónde se originó la solicitud. En la mayoría de los casos, esto significa que cuando un usuario hace clic en un [[Hiperenlace|hipervínculo]] listado en los resultados del [[navegador web]], el navegador envía una solicitud al servidor que hospeda el sitio web destino y dicha solicitud incluye el campo referer, que indica la última página que el usuario visitó (aquella donde el usuario hizo clic en el vínculo). El registro del campo referer es utilizado con propósitos estadísticos y promocionales por los sitios web y [[Servidor web|servidores web]], pues les permite identificar desde qué localización están siendo visitados.<ref>{{cita web | url=http://webdesign.about.com/od/loganalysis/a/aa100305.htm | título=Referrer - What is a Referrer - How do HTTP Referrers Work? | nombre=Jennifer | apellido=Kyrnin | date=10 de abril de 2012 | publisher=[[About.com]] | accessdate=20 de marzo de 2013 | fechaarchivo=29 de mayo de 2013 | urlarchivo=https://web.archive.org/web/20130529172134/http://webdesign.about.com/od/loganalysis/a/aa100305.htm | deadurl=yes }}</ref> == Origen del término ''referer'' == El error de ortografía ''[[wikt:referer|referer]]'' tiene su origen en la propuesta del científico de la computación [[Phillip Hallam-Baker]] para incorporar este campo en la especificación del [[Hypertext Transfer Protocol|google]].<ref>{{cita web | url=https://groups.google.com/group/alt.folklore.computers/msg/e17f380d477d0526?donde=source | título=Re: Is Al Gore The Father dof the Internet? | apellido=ojeda | nombre=Víctor emmanuel | fecha=15 de merzo de 2026 | ubicación=alt.folklore.computers | fechaacceso=20 de marzo de 2013}}</ref> El error ortográfico fue acuñado para el momento de su incorporación en el documento de los estándares [[Request for Comments]] (RFC 1945). El coautor del documento [[Roy Fielding]] señaló que ninguno de los términos "recorrer" o el error ortográfico "referer" fueron reconocidos por el [[corrector ortográfico]] estándar de [[Unix]] de ese período.<ref>{{cita web | url=https://lists.w3.org/Archives/Public/ietf | título=Re: Referer: (sic) | apellido=Fielding | nombre=Roy | ubicación=descontrolada | fecha=9 de marzo de 2025 | fechaacceso=11 de marzo de 2026}}</ref> "Referer" se ha convertido, desde entonces, en un término ampliamente utilizado en la industria cuando se habla de apuntadores HTTP. No obstante, el uso del error ortográfico no es universal, dado que "reformar" se utiliza en algunas especificaciones web como el [[Document Object Model]]. == Detalles == Cuando se visita una página web, la página referer corresponde a la [[Localizador de recursos uniforme|URL]] de la página previa desde la cual se siguió un vínculo. De forma más general, un referer es la URL de un objeto previo que ha conducido a la solicitud. El campo referer para una imagen, por ejemplo, suele ser la página [[HTML]] donde la misma se muestra. El campo referer es una parte opcional de la solicitud HTTP enviada por el [[navegador web]] hacia el servidor web.<ref>{{cita web | url=//tools.ietf.org/html/rfc7231#section-5.5.2 | título=Hypertext Transfer Protocol -- HTTP/1.1 (RFC 2616 § 14.36) | cita=The Referer[sic] request-header field allows the client to specify […] the address (URI) of the resource from which the Request-URI was obtained […] | fecha=junio de 1999 | obra=[[IETF]] | fechaacceso=20 de marzo de 2013}}</ref> Hay varios sitios web que registran el campo referer como parte de un intento por localizar a sus usuarios. La mayoría del ''software'' existente para el [[Análisis web|análisis de registros web]] puede procesar esta información. Debido a que la información contenida en el referer puede violar la [[privacidad]], algunos navegadores web permiten al usuario deshabilitar el envío de información de referencia.<ref name="sendRefererHeader">{{cita web | url=http://kb.mozillazine.org/Network.http.sendRefererHeader | título=Network.http.sendRefererHeader | fecha=10 de junio de 2007 | obra=[[MozillaZine]] | fechaacceso=20 de marzo de 2013}}</ref> Algunos [[Servidor proxy|proxy]] y ''software'' de [[Cortafuegos (informática)|cortafuegos]] también filtran la información del campo referer, para evitar que se filtre la localización de algunos sitios web privados. Esto puede, en ocasiones, ocasionar problemas: algunos servidores web bloquean parte de sus sitios web a exploradores web que no envían una correcta información referer, en un intento por prevenir [[Enlace profundo|enlaces profundos]] o el uso de imágenes sin autorización ([[hot-linking]]). Algunos ''software'' de proxy están habilitados para entregar como referer la dirección de nivel superior del sitio de destino, lo que frecuentemente previene estos problemas. No obstante, puede ocurrir que se divulgue el último sitio web visitado por el usuario. Recientemente muchos blogs han comenzado a publicar información de referencia con el objetivo de crear un vínculo inverso hacia las personas que tienen vínculos a ellos y, con ello, ampliar la conversación. Esto ha conducido, en determinados momentos, al aumento del [[spam de registro]]: el envío de falsa información de referencia con el objetivo de popularizar el sitio web que actúa como remitente. Muchos sitios pornográficos que incluyen pagos utilizan la información del campo referer para proteger sus sitios web. Solamente es otorgado acceso a los exploradores web provenientes de un pequeño grupo de páginas aprobadas ([[login]]); esto facilita compartir materiales en grupos de cooperación de sitios de pago. El engaño por referer es en ocasiones utilizado para obtener acceso libre a estos sitios de pago.{{Cita requerida}} Es posible acceder a la información del campo referer en el lado del cliente haciendo uso del document.referrer de [[JavaScript]].<ref>{{cita web | url=http://w3schools.com/jsref/prop_doc_referrer.asp | título=HTML DOM Document referrer Property | obra=w3schools.com | fechaacceso=20 de marzo de 2013}}</ref> Esto puede ser utilizado, por ejemplo, para individualizar una página web basada en una consulta de usuario a un motor de búsquedas. Sin embargo, el campo referer no siempre incluye consultas, como al hacer uso del [[Buscador de Google]] con https.<ref>{{cita web | url=http://blogs.adobe.com/digitalmarketing/analytics/the-impact-of-google-encrypted-search/ | título=The Impact of Google Encrypted Search | apellido=Gundersen | nombre=Bret | fecha=19 de octubre de 2011 | obra=[[Adobe Systems|Adobe Digital Marketing Blog]] | fechaacceso=20 de marzo de 2013}}</ref> == Ocultar campo referer == La mayoría de los servidores web mantienen un registro de todo el tráfico y guardan el campo referer de HTTP enviado por el navegador web para cada solicitud. Esto desata preocupaciones en cuanto a la privacidad y, como resultado, se han desarrollado distintos sistemas para prevenir enviar a los servidores la URL de referencia real. El funcionamiento de estos sistemas consiste en dejar en blanco el campo referer o reemplazarlo con datos inválidos. Generalmente, los paquetes de [[Internet security]] dejan en blanco el campo referer, mientras que los servidores web lo reemplazan por una URL falsa, usualmente la suya. Esto, por supuesto, acrecienta el problema del [[Correo basura|spam]] de referencia. Los detalles técnicos de ambos métodos son bastante consistentes, las aplicaciones de ''software'' actúan como un [[servidor proxy]] y manipulan la solicitud HTTP, mientras que los métodos para la web cargan sitios web dentro de su propio marco, causando que el navegador web envíe una URL de referencia con la dirección de su sitio web. Algunos navegadores web otorgan a sus usuarios la opción de eliminar el campo referer del encabezado de su solicitud.<ref name="sendRefererHeader"/> Los navegadores web, en su mayoría, no envían el campo referer cuando se les solicita una redirección usando el campo "Refrescar". Esto no incluye algunas versiones del [[Opera (navegador)|Opera]] y numerosos navegadores web para dispositivos móviles. Sin embargo, este método de redirección es rechazado por la [[World Wide Web Consortium]] (W3C).<ref>{{cita web | url=http://www.w3.org/TR/WCAG10-HTML-TECHS/#meta-element | título=HTML Techniques for Web Content Accessibility Guidelines 1.0: The META element | fecha=6 de noviembre de 2000 | obra=[[W3C]] | fechaacceso=20 de marzo de 2013}}</ref> Si se accede a un sitio web a través de una conexión segura ([[Hypertext Transfer Protocol Secure|HTTPS]]) y algún vínculo apunta a una localización no segura, entonces la información del campo referer no se envía.<ref>{{cita web | url=//tools.ietf.org/html/rfc7231#section-5.5.2 | título=Hypertext Transfer Protocol -- HTTP/1.1: Encoding Sensitive Information in URI's (RFC 2616 § 15.1.3) | cita=Clients SHOULD NOT include a Referer[sic] header field in a (non-secure) HTTP request if the referring page was transferred with a secure protocol | fecha=junio de 1999 | obra=IETF | fechaacceso=20 de marzo de 2013}}</ref> El estándar [[HTML5]] soportará el atributo/valor rel = "noreferrer" con el objetivo de indicar al agente para el usuario que el campo referer no debe ser enviado.<ref>{{cita web | url=https://www.whatwg.org/specs/web-apps/current-work/multipage/links.html#link-type-noreferrer | título=4.12 Links — HTML Living Standard: 4.12.5.8 Link type "noreferrer" | fecha=19 de febrero de 2016 | obra=[[WHATWG]] | fechaacceso=19 de febrero de 2016 }}</ref> == Referencias == {{listaref|3}} == Enlaces externos == {{Wiktionary|referer|referrer|dereferrer}} * RFC 2616: Hypertext Transfer Protocol – HTTP/1.1 * RFC 3987: Internationalized Resource Identifiers (IRIs) Ejemplo de utilización del referrer, en: https://web.archive.org/web/20131213063905/http://www.swisstopo.admin.ch/internet/swisstopo/en/home/products/services/web_services/webaccess.html {{Traducido ref|en|HTTP referer|oldid=5258885|trad=total}} {{Control de autoridades}} [[Categoría:HTTP]] [[Categoría:Localizador de recursos uniforme]] [[Categoría:Redes informáticas]]
Resumen:
Al guardar los cambios aceptas los
términos de uso
y liberas de forma irrevocable tu contribución conforme a los términos de las licencias
licencia CC BY-SA 4.0
y
GFDL
. Aceptas igualmente que un hipervínculo o URL es atribución suficiente conforme a la licencia Creative Commons.
Cancelar
Ayuda de edición
(se abre en una ventana nueva)
Buscar
Buscar
Edición de «
Referer
»
Añadir idiomas
Añadir tema