Ir al contenido
Menú principal
Menú principal
mover a la barra lateral
ocultar
Navegación
Página principal
Cambios recientes
Página aleatoria
Ayuda sobre MediaWiki
Buscar
Buscar
español
Apariencia
Crear una cuenta
Acceder
Herramientas personales
No has accedido
Discusión
Contribuciones
Crear una cuenta
Acceder
Edición de «
GSSAPI
»
Página
Discusión
español
Leer
Editar
Editar código
Ver historial
Herramientas
Herramientas
mover a la barra lateral
ocultar
Acciones
Leer
Editar
Editar código
Ver historial
General
Lo que enlaza aquí
Cambios relacionados
Información de la página
Apariencia
mover a la barra lateral
ocultar
Advertencia:
no has iniciado sesión. Tu dirección IP se hará pública si haces cualquier edición. Si
inicias sesión
o
creas una cuenta
, tus ediciones se atribuirán a tu nombre de usuario, además de otros beneficios.
Comprobación antispam. ¡
No
rellenes esto!
{{referencias|t=20130113|informática}} GSSAPI (del inglés ''Generic Security Service Application Program Interface''), o también GSS-API, es un API (Interfaz de Programación de Aplicación) para usar sistemas de seguridad de forma genérica. GSSAPI es un estándar de la [[IETF]] que aborda el problema que implica la existencia en la actualidad de muchos sistemas de seguridad similares pero incompatibles. El sistema de seguridad más común que se utiliza mediante la GSS API es [[Kerberos]]. == Cómo funciona == GSSAPI, por sí mismo, no ofrece ninguna seguridad. En lugar de eso, los fabricantes de sistemas de seguridad ofrecen implementaciones de GSSAPI en forma de [[Biblioteca (programación)|bibliotecas]] que se distribuyen junto con su software de seguridad. Esas bibliotecas presentan una interfaz compatible con GSSAPI a los programadores de aplicaciones que pueden escribir sus programas utilizando únicamente GSSAPI [[Normalización|normalizado]]. De ese modo, si se necesita reemplazar la implementación del sistema de seguridad, no es necesario reescribir la aplicación. La principal característica de las aplicaciones GSSAPI es el intercambio de mensajes opacos ''(tokens)'' que ocultan los detalles de implementación de los niveles superiores de la aplicación. Los lados de cliente y servidor de la aplicación se escriben para transmitir los mensajes (''tokens'') que reciben de sus respectivas implementaciones GSSAPI. Los mensajes GSSAPI pueden viajar a través de una red insegura como mecanismo para proporcionar seguridad a los mensajes. Tras el intercambio de algunos mensajes, las implementaciones GSSAPI en ambos extremos informan a su aplicación local que se ha establecido un ''contexto de seguridad''. Una vez establecido el contexto de seguridad, los mensajes de aplicación sensibles se pueden envolver (codificados) por el GSSAPI para una comunicación segura entre el cliente y el servidor. Las protecciones garantizadas por la capa GSSAPI incluyen confidencialidad (secreto) y la integridad (autenticidad). El GSSAPI también puede proporcionar, en local, garantías acerca de la identidad del usuario o el host remoto. El GSSAPI describe cerca de 45 llamadas de procedimiento. Las más significativas son: * ''GSS_Acquire_cred:'' Obtiene una prueba de identidad del usuario, a menudo una clave criptográfica secreta * ''GSS_Import_name:'' Convierte un nombre de usuario o nombre de host en un identificador de una entidad de seguridad * ''GSS_Init_sec_context:'' Genera un mensaje que el cliente envía al servidor, por lo general un desafío * ''GSS_Accept_sec_context:'' Procesa un mensaje de ''GSS_Init_sec_context'' y puede generar un mensaje de respuesta * ''GSS_Wrap:'' Convierte los datos de aplicación en un mensaje seguro (normalmente cifrado) * ''GSS_Unwrap:'' Convierte un mensaje seguro en datos de la aplicación El GSSAPI ha sido estandarizado para el [[lenguaje C]] ([[rfc:2744|RFC 2744]]). [[Java (lenguaje de programación)|Java]] implementa GSSAPI como JGSS. Las limitaciones más importantes de la GSSAPI son: que estandariza únicamente la autenticación y no la autorización y que asume una arquitectura cliente-servidor. Anticipando nuevos mecanismos de seguridad, el GSSAPI incluye un mecanismo de pseudo negociación, SPNEGO, que puede descubrir y utilizar nuevos mecanismos no presentes cuando la aplicación original fue construida. == Enlaces externos == * RFC 2743 The Generic Security Service API Version 2 update 1 (''en inglés'') * RFC 2744 The Generic Security Service API Version 2: C-Bindings (''en inglés'') * RFC 1964 The Kerberos 5 GSS-API mechanism (''en inglés'') * RFC 4121 The Kerberos 5 GSS-API mechanism: Version 2 (''en inglés'') * RFC 4178 The Simple and Protected GSS-API Negotiation Mechanism (SPNEGO) (''en inglés'') * RFC 2025 The Simple Public-Key GSS-API Mechanism (SPKM) (''en inglés'') * RFC 2847 LIPKEY - A Low Infrastructure Public Key Mechanism Using SPKM (''en inglés'') * {{cite web | url=https://datatracker.ietf.org/wg/kitten/charter/ | title=Common Authentication Technology Next Generation (kitten) | date=September 2013 | publisher=[[Internet Engineering Task Force]]}} * {{cite web | url=https://docs.oracle.com/cd/E19683-01/816-1331/ | title=GSS-API Programming Guide | date=2002 | author=[[Sun Microsystems]] | publisher=[[Oracle Corporation]]}} {{Control de autoridades}} [[Categoría:Acrónimos]] [[Categoría:Seguridad del sistema operativo]]
Resumen:
Al guardar los cambios aceptas los
términos de uso
y liberas de forma irrevocable tu contribución conforme a los términos de las licencias
licencia CC BY-SA 4.0
y
GFDL
. Aceptas igualmente que un hipervínculo o URL es atribución suficiente conforme a la licencia Creative Commons.
Cancelar
Ayuda de edición
(se abre en una ventana nueva)
Buscar
Buscar
Edición de «
GSSAPI
»
Añadir idiomas
Añadir tema