Ir al contenido
Menú principal
Menú principal
mover a la barra lateral
ocultar
Navegación
Página principal
Cambios recientes
Página aleatoria
Ayuda sobre MediaWiki
Buscar
Buscar
español
Apariencia
Crear una cuenta
Acceder
Herramientas personales
No has accedido
Discusión
Contribuciones
Crear una cuenta
Acceder
Editando
NETCONF
(sección)
Página
Discusión
español
Leer
Editar
Editar código
Ver historial
Herramientas
Herramientas
mover a la barra lateral
ocultar
Acciones
Leer
Editar
Editar código
Ver historial
General
Lo que enlaza aquí
Cambios relacionados
Información de la página
Apariencia
mover a la barra lateral
ocultar
Advertencia:
no has iniciado sesión. Tu dirección IP se hará pública si haces cualquier edición. Si
inicias sesión
o
creas una cuenta
, tus ediciones se atribuirán a tu nombre de usuario, además de otros beneficios.
Comprobación antispam. ¡
No
rellenes esto!
== Capas de protocolo == === Contenido === El contenido de las operaciones de NETCONF es un XML bien formado. La mayoría de contenido está relacionado con [[Gestión de red|administración de]] red. Posteriormente se agregó soporte para codificar en [[JSON|Notación de Objeto del Javascript]] (JSON) también. El grupo de trabajo NETMOD ha completado trabajo para definir un lenguaje de modelamiento "amistoso para el humano" para definir la semántica de datos operacionales, datos de configuración, notificaciones y operaciones, llamado YANG. YANG está definido en RFC 6020 (versión 1) y RFC 7950 (versión 1.1), y está acompañado por el "Tipos de Datos comunes YANG" definidos en RFC 6991. Durante el verano de 2010, el grupo de trabajo NETMOD fue re-comisionado para trabajar en modelos de configuración del núcleo (sistema, interfaz, y encaminamiento) así como trabajar en compatibilidad con el lenguaje de modelamiento [[Protocolo simple de administración de red|SNMP]]. === Operaciones === El protocolo de base define las operaciones de protocolo siguientes: {| class="wikitable" !Operación !Descripción |- |<get> |Recupera la configuración activa y la información del estado del dispositivo |- |<get-config> |Recupera todo o parte de los datos de una configuración especificada |- |<Edit-config> |Editar una configuración de datos al crear, eliminar, fusionar o reemplazar contenido |- |<Copy-config> |Copia una configuración entera a otra configuración |- |<delete-config> |Eliminar los datos de una configuración |- |<lock> |Bloquea los datos de una configuración entera de un dispositivo |- |<unlock> |Liberación de datos de configuración anteriormente obtenidos con la operación <lock> |- |<close-session> |Pedir la terminación correcta de una sesión NETCONF |- |<kill-session> |Fuerza la terminación de una sesión NETCONF |- |} La funcionalidad básica de NETCONF puede ser extendida por la definición de capacidades NETCONF. El conjunto de funcionalidades adicionales que son soportados en una implementación se comunica entre el servidor y el cliente durante la porción de intercambio de la capacidad de la puesta en marcha de la sesión. Las características obligatorias del protocolo obligatorio no se incluyen en el intercambio de capacidad ya que se asumen presentes. El<nowiki/>RFC 4741 define un número de las capacidades opcionales que incluyen :xpath y :validate. Es necesario notar que el RFC 6241 deja obsoleto el RFC 4741. Una capacidad para permitir suscribir y recibir notificaciones de eventos asíncronos fue publicada en [rfc:5277 RFC 5277.] Este documento define la operación <crear-suscripción> (''<create-subscription>''), el cual habilita crear suscripciones en tiempo-real y de replay. Las notificaciones son enviadas en forma asincrónica utilizando el constructo <notificación> (''<notification>)''. También define la capacidad :interleave, la cual facilita la modificación de la subscripción al permitir el procesamiento de otras operaciones NETCONF mientras la suscripción está activa. Una capacidad para permitir el bloqueo parcial de la configuración en uso está definida en [rfc:5717 RFC 5717.] Esto permite que múltiples sesiones editen subárboles no superpuestos dentro de la configuración en uso. Sin esta capacidad, la única posibilidad de bloqueo sería bloquear toda la configuración. Una capacidad para controlar el protocolo NETCONF está definido en [rfc:6022 RFC 6022.] Este documento contiene un modelo de datos que incluye información sobre los registros de datos NETCONF, sesiones, bloqueos, y estadísticas que facilita la administración de un servidor NETCONF. También define métodos para clientes NETCONF para descubrir modelos de datos soportados por un servidor NETCONF y define la operación ''<get-schema>'' para recuperarles. === Mensajes === La capa de mensajes de NETCONF proporciona un mecanismo marco sencillo, independiente del transporte para codificar * Invocaciones RPC (mensajes <rpc>), * Resultados RPC (mensajes <rpc-reply>), y * Notificaciones de acontecimiento (mensajes de <notificación>). Cada mensaje NETCONF es un documento XML bien-formado. Un resultado RPC está enlazado a una invocación RPC por un atributo id-mensaje. Los mensajes NETCONF pueden ser ejecutados en serie, i.e., un cliente puede invocar múltiple RPCs sin tener que esperar los mensajes de resultado RPC primero. Los mensajes RPC están definidos en RFC 6241 y los mensajes de notificación están definidos en RFC 5277.
Resumen:
Al guardar los cambios aceptas los
términos de uso
y liberas de forma irrevocable tu contribución conforme a los términos de las licencias
licencia CC BY-SA 4.0
y
GFDL
. Aceptas igualmente que un hipervínculo o URL es atribución suficiente conforme a la licencia Creative Commons.
Cancelar
Ayuda de edición
(se abre en una ventana nueva)
Buscar
Buscar
Editando
NETCONF
(sección)
Añadir idiomas
Añadir tema