Ir al contenido
Menú principal
Menú principal
mover a la barra lateral
ocultar
Navegación
Página principal
Cambios recientes
Página aleatoria
Ayuda sobre MediaWiki
Buscar
Buscar
español
Apariencia
Crear una cuenta
Acceder
Herramientas personales
No has accedido
Discusión
Contribuciones
Crear una cuenta
Acceder
Editando
NETCONF
(sección)
Página
Discusión
español
Leer
Editar
Editar código
Ver historial
Herramientas
Herramientas
mover a la barra lateral
ocultar
Acciones
Leer
Editar
Editar código
Ver historial
General
Lo que enlaza aquí
Cambios relacionados
Información de la página
Apariencia
mover a la barra lateral
ocultar
Advertencia:
no has iniciado sesión. Tu dirección IP se hará pública si haces cualquier edición. Si
inicias sesión
o
creas una cuenta
, tus ediciones se atribuirán a tu nombre de usuario, además de otros beneficios.
Comprobación antispam. ¡
No
rellenes esto!
== Historia == El IETF desarrolló el [[Protocolo simple de administración de red|Protocolo de Administración de Red Sencillo]] (SNMP) a fines de los 80s y resultó ser un [[Protocolo de comunicaciones|protocolo]] de administración de red muy popular. En la parte temprana del {{siglo|XXI||s}} se hace aparente que a pesar de lo que se intentó originalmente, SNMP no estaba siendo utilizado para configurar equipamiento de red, sino que principalmente era utilizado para [[monitoreo de red]]. En junio del 2002, el [[Internet Architecture Board|Directorio de Arquitectura del Internet]] y algunos miembros claves de la comunidad de administración de red del IETF se reunieron con operadores de red para discutir la situación. Los resultados de esta reunión se documentaron en [rfc:3535 RFC 3535.] Resultó que los operadores principalmente utilizaban [[Interfaz de línea de comandos|Interfaces de Línea de]] Orden propietarias (CLI) para configurar sus dispositivos. Esto tenía una cantidad de características que a los operadores les gustaba, incluyendo el hecho que estaba basado en texto, en oposición al SNMP que estaba codificado en BER. Además, muchos vendedores de equipamiento no proporcionaban la opción para configurar completamente sus dispositivos vía SNMP. Aun cuando a los operadores generalmente les gustaba escribir scripts para facilitar la configuración de sus cajas, encontraban que el CLI SNMP era insuficiente en varios temas. Aún más importante era la naturaleza imprevisible del resultado. El contenido y formato del resultado era propenso a cambiar de maneras imprevisibles. Más o menos al mismo tiempo, [[Juniper Networks]] había tomado una aproximación de administración de red utilizando XML. Esto se compartió con IETF y luego se compartió con el resto de la comunidad. En conjunto, estos dos acontecimientos dirigieron el IETF en mayo de 2003 a la creación del NETCONF grupo laborable. Este grupo de trabajo fue comisionado para trabajar en un protocolo de configuración de la red, el cual alineara mejor las necesidades de los operadores de red y de los vendedores de equipamiento. La primera versión del protocolo base de NETCONF fue publicado como RFC 4741 en diciembre de 2006. Varias extensiones se publicaron en años subsiguientes (notificaciones en RFC 5277 en julio del 2008, cierres parciales en RFC 5717 en diciembre del 2009, valores por defecto en RFC 6243 en junio del 2011, notificaciones de sistema en RFC 6470 en febrero del 2012, control de acceso en RFC 6536 en marzo de 2012). Una versión revisada del protocolo base de NETCONF fue publicado como RFC 6241 en junio de 2011.
Resumen:
Al guardar los cambios aceptas los
términos de uso
y liberas de forma irrevocable tu contribución conforme a los términos de las licencias
licencia CC BY-SA 4.0
y
GFDL
. Aceptas igualmente que un hipervínculo o URL es atribución suficiente conforme a la licencia Creative Commons.
Cancelar
Ayuda de edición
(se abre en una ventana nueva)
Buscar
Buscar
Editando
NETCONF
(sección)
Añadir idiomas
Añadir tema