Ir al contenido
Menú principal
Menú principal
mover a la barra lateral
ocultar
Navegación
Página principal
Cambios recientes
Página aleatoria
Ayuda sobre MediaWiki
Buscar
Buscar
español
Apariencia
Crear una cuenta
Acceder
Herramientas personales
No has accedido
Discusión
Contribuciones
Crear una cuenta
Acceder
Edición de «
Cryptographic Message Syntax
»
Página
Discusión
español
Leer
Editar
Editar código
Ver historial
Herramientas
Herramientas
mover a la barra lateral
ocultar
Acciones
Leer
Editar
Editar código
Ver historial
General
Lo que enlaza aquí
Cambios relacionados
Información de la página
Apariencia
mover a la barra lateral
ocultar
Advertencia:
no has iniciado sesión. Tu dirección IP se hará pública si haces cualquier edición. Si
inicias sesión
o
creas una cuenta
, tus ediciones se atribuirán a tu nombre de usuario, además de otros beneficios.
Comprobación antispam. ¡
No
rellenes esto!
El '''Cryptographic Message Syntax''' (CMS) es un estándar de la [[IETF]] para proteger mensajes criptográficamente. En él se definen las sintaxis para firmar digitalmente, realizar hash, realizar mac o para cifrar cualquier [[tipo de dato]]. CMS se basa en la sintaxis de [[PKCS]]#7, que a su vez se basa en el estándar [[Privacy-enhanced Electronic Mail|Privacy-Enhanced Mail]]. La versión más moderna de CMS se define en la RFC 5652 (ver también la RFC 5911 de módulos [[ASN.1]] acordes al estándar ASN.1 2002). CMS se construye alrededor del sistema de manejo de claves [[X.509|certificate-based]] así como el perfil definido por [[PKIX]] [[working group]]. CMS se usa como el componente clave para muchos otros estándares criptográficos como [[S/MIME]], [[PKCS]]#12 y el protocolo de sellado digital (RFC 3161). [[OpenSSL]] es un software de código libre que permite cifrar, descifrar, firmar, verificar, comprimir y descomprimir documentos acordes a este estándar. ==Normas y estándares== CMS está en constante desarrollo: *RFC 2315 - PKCS # 7 Versión 1.5 (obsoleto). *RFC 2630 - CMS 1.0, junio de 1999 (obsoleto). *RFC 3369 - CMS 2.0, agosto de 2002 (obsoleto). *RFC 3852 - CMS 3.0, julio de 2005 (obsoleto). *RFC 5652 - CMS 4.0, septiembre de 2009 (actual): **RFC 8933 : actualización del CMS para la protección de identificadores de algoritmos, octubre de 2020. ==Véase también== * [[CAdES (informática)|CAdES - CMS Advanced Electronic Signatures]] * [[S/MIME]] * [[PKCS]] #7 ==Enlaces externos== * [http://msdn.microsoft.com/de-de/library/ms180945.aspx Información sobre''System.Security.Cryptography.Pkcs''] ==Referencias== *Jörg Schwenk: Seguridad y [[criptografía]] en Internet. Desde correo electrónico seguro hasta cifrado de IP. 2ª edición ampliada y mejorada. Vieweg + Teubner Verlag, Wiesbaden 2005,ISBN 3-8348-0042-2 (''Studium''). {{Reflist}} * {{IETF RFC|8933}} (Cryptographic Message Syntax (CMS), in use) * {{IETF RFC|5652}} (Cryptographic Message Syntax (CMS), obsolete) * {{IETF RFC|3852}} (Cryptographic Message Syntax (CMS), obsolete) * {{IETF RFC|3369}} (Cryptographic Message Syntax (CMS), obsolete) * {{IETF RFC|2630}} (Cryptographic Message Syntax, obsolete) * {{IETF RFC|6268}} (New ASN.1 Modules for Cryptographic Message Syntax (CMS) and S/MIME, in use) * {{IETF RFC|5911}} (New ASN.1 Modules for Cryptographic Message Syntax (CMS) and S/MIME, updated) * {{IETF RFC|5753}} (Using Elliptic Curve Cryptography with CMS, in use) * {{IETF RFC|3278}} (Use of Elliptic Curve Cryptography (ECC) Algorithms in Cryptographic Message Syntax (CMS), obsolete) * {{IETF RFC|5084}} (Using AES-CCM and AES-GCM Authenticated Encryption in the Cryptographic Message Syntax (CMS), in use) {{Control de autoridades}} [[Categoría:Cifrados clásicos]] [[Categoría:Criptografía]]
Resumen:
Al guardar los cambios aceptas los
términos de uso
y liberas de forma irrevocable tu contribución conforme a los términos de las licencias
licencia CC BY-SA 4.0
y
GFDL
. Aceptas igualmente que un hipervínculo o URL es atribución suficiente conforme a la licencia Creative Commons.
Cancelar
Ayuda de edición
(se abre en una ventana nueva)
Buscar
Buscar
Edición de «
Cryptographic Message Syntax
»
Añadir idiomas
Añadir tema